jeongabae / Baekjoon_Python

파이썬으로 푼 백준 - 2023.02.05 누적 440문제, 파이썬으로 푼 코드업 - 기초 100제 풀이 완료
0 stars 0 forks source link

[EASY] 백준 17863번 : FYI #278

Closed jeongabae closed 2 years ago

jeongabae commented 2 years ago

브론즈4

오늘은 그냥 커밋용..

시간 제한 | 메모리 제한 | 제출 | 정답 | 맞힌 사람 | 정답 비율 -- | -- | -- | -- | -- | -- 1 초 | 512 MB | 1595 | 1282 | 1201 | 80.334%

문제

In the United States of America, telephone numbers within an area code consist of 7 digits: the prefix number is the first 3 digits and the line number is the last 4 digits. Traditionally, the 555 prefix number has been used to provide directory information and assistance as in the following examples:

  • 555-1212
  • 555-9876
  • 555-5000
  • 555-7777

Telephone company switching hardware would detect the 555 prefix and route the call to a directory information operator. Now-a-days, telephone switching is done digitally and somewhere along the line a computer decides where to route calls.

For this problem, write a program that determines if a supplied 7-digit telephone number should be routed to the directory information operator, that is, the prefix number is 555.

입력

The input consists of a single line containing a 7-digit positive integer N, (1000000 <= N <= 9999999).

출력

The single output line consists of the word YES if the number should be routed to the directory information operator or NO if the number should not be routed to the directory information operator.

예제 입력 1 

5551212

예제 출력 1 

YES

예제 입력 2 

5519876

예제 출력 2 

NO

예제 입력 3 

5055555

예제 출력 3 

NO

예제 입력 4 

5550000

예제 출력 4 

YES

제출한 코드

N=input()[0:3] #input()[:3]와 같음
print('YES' if N=='555' else 'NO')