JohnTargaryen / Learning-C-

1 stars 0 forks source link

POJ 2499 binarytree #4

Open JohnTargaryen opened 7 years ago

JohnTargaryen commented 7 years ago

Description

Binary Tree Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 6962 Accepted: 3176 Description

Background Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: The root contains the pair (1, 1). If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child? Input

The first line contains the number of scenarios. Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent a node (i, j). You can assume that this is a valid node in the binary tree described above. Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario. Sample Input

3 42 1 3 4 17 73 Sample Output

Scenario #1: 41 0

Scenario #2: 2 1

Scenario #3: 4 6 Source

TUD Programming Contest 2005 (Training Session), Darmstadt, Germany


Solution1

#include<iostream>
using namespace std;

int main() {
    int n;
    cin >> n;
    for (int i = 0; i < n; i++) {
        int a, b, max, left = 0, right = 0;
        cin >> a;
        cin >> b;
        while (a != 1 || b != 1) {
            if (a > b) {
                max = a;
                a = max - b;
                left++;
            }
            else {
                max = b;
                b = max - a;
                right++;
            }
        }
        cout << "Scenario #" << i+1 << ":" << endl;
        cout << left << " " << right << endl;
    }
}

Time limit exceeded occurs; For the input data is as big as 2000000000;


Solution2

Use division instead of multiple substractions;

#include<iostream>
using namespace std;

int main() {
    int n;
    cin >> n;
    for (int i = 0; i < n; i++) {
        int a, b, max, left = 0, right = 0;
        cin >> a;
        cin >> b;
        while ((a != 1 || b != 1)&& (a!=0 && b != 0)) {
            if (a > b) {
                max = a;
                if (b == 1)
                    left -= 1;
                a = max % b;
                left += max / b;
            }
            else {
                max = b;
                if (a == 1)
                    right -= 1;
                b = max % a;
                right += max / a;
            }
        }
        cout << "Scenario #" << i + 1 << ":" << endl;
        cout << left << " " << right << endl;
    }
}