jakartaee / rest

Jakarta RESTful Web Services
Other
350 stars 113 forks source link

Maven wrapper too old for build #1263

Closed yawkat closed 3 weeks ago

yawkat commented 1 month ago

The mvnw script is configured to use maven 3.8.4, which is too old to compile the project:

[ERROR] Failed to execute goal org.asciidoctor:asciidoctor-maven-plugin:3.0.0:process-asciidoc (asciidoc-to-html) on project jakarta.ws.rs-spec: The plugin org.asciidoctor:asciidoctor-maven-plugin:3.0.0 requires Maven version 3.8.5 -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginIncompatibleException
[ERROR] 
mkarg commented 1 month ago

Are you sure that this is solely cause by Maven itself? Maybe it could get fixed by upgrading the asciidoctor-maven-plugin?