maninbule / LanQiaoCup

蓝桥杯刷题活动
0 stars 0 forks source link

466. 回文日期 #29

Open maninbule opened 4 years ago

maninbule commented 4 years ago

466. 回文日期

在日常生活中,通过年、月、日这三个要素可以表示出一个唯一确定的日期。

牛牛习惯用 8 位数字表示一个日期,其中,前 4 位代表年份,接下来 2 位代表月份,最后 2 位代表日期。

显然:一个日期只有一种表示方法,而两个不同的日期的表示方法不会相同。

牛牛认为,一个日期是回文的,当且仅当表示这个日期的8位数字是回文的。

现在,牛牛想知道:在他指定的两个日期之间(包含这两个日期本身),有多少个真实存在的日期是回文的。

一个 8 位数字是回文的,当且仅当对于所有的 i(1≤i≤8) 从左向右数的第i个数字和第 9−i 个数字(即从右向左数的第 i 个数字)是相同的。

例如:

•对于2016年11月19日,用 8 位数字 20161119 表示,它不是回文的。

•对于2010年1月2日,用 8 位数字 20100102 表示,它是回文的。

•对于2010年10月2日,用 8 位数字 20101002 表示,它不是回文的。

输入格式

输入包括两行,每行包括一个8位数字。

第一行表示牛牛指定的起始日期date1,第二行表示牛牛指定的终止日期date2。保证date1和date2都是真实存在的日期,且年份部分一定为4位数字,且首位数字不为0。

保证date1一定不晚于date2。

输出格式

输出共一行,包含一个整数,表示在date1和date2之间,有多少个日期是回文的。

输入样例:

20110101
20111231

输出样例:

1
maninbule commented 4 years ago
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

string s1,s2;
int cnt = 0;
int y1,y2;
int mth[] = {0,31,29,31,30,31,30,31,31,30,31,30,31};
int to_int(string str,int s,int e){
    int res = 0;
    for(int i = s;i<=e;i++) res = res*10+str[i]-'0';
    return res;
}

bool is_run(int year){
    if ((year % 4 == 0 && year % 100 != 0) || ( year % 400 == 0)) return true;
    return false;
}

bool isok(string &s){
    if(s>s2 || s<s1) return false;
    int y = to_int(s,0,3),m = to_int(s,4,5),d = to_int(s,6,7);
    if(m == 2 && d == 29 && !is_run(y)) return false;
    return (1 <= m && m <= 12) && (1 <= d && d <= mth[m]);
}
int main(){
    cin>>s1>>s2;
    y1 = to_int(s1,0,3);
    y2 = to_int(s2,0,3);
    for(int y = y1;y<=y2;y++){
        string cur = to_string(y);
        while(cur.length()<4) cur = "0"+cur;
        string p = cur;
        reverse(cur.begin(),cur.end());
        cur = p+cur;
        if(isok(cur)) cnt++;
    }
    cout<<cnt<<endl;
    return 0;
}
patern2000 commented 4 years ago

include

include

include

using namespace std;

int run[13]={0,31,29,31,30,31,30,31,31,30,31,30,31}; int ping[13]={0,31,28,31,30,31,30,31,31,30,31,30,31}; vector v1; vector v2; int check(int num){ int year =num/10000; int month=num%10000/100; int day=num%10000%100; if(month<=0||month>12) return 0; if(year%100&&year%4==0||year%400==0){ if(day==0||day>run[month]) return 0; } else{ if(day==0||day>ping[month]) return 0; } return 1; } // int huiwen(int num){ // int i=0; // while(num){ // if(i==4) break; // v1.push_back(num%10); // i++; // num/=10; // } // while(num){ // v2.push_back(num%10); // num/=10; // } // reverse(v2.begin(),v2.end()); // for(int j=0;j<4;j++){ // if(v1[j]!=v2[j]) return 0; // } // return 1; // } int main() { int date1,date2; int ans=0; cin>>date1>>date2; for (int i =1000; i < 10000; i ++ ) { int x=i,date=i; for (int j=0;j<4;j++) date = date*10+x%10,x/=10; if (date >=date1&&date<=date2&&check(date)) ans++; }

cout<<ans<<endl;

return 0;

}

consult98 commented 4 years ago
#include<iostream>
#include<algorithm>
using namespace std;

struct node{
    int year,mou,day;
}A,B;
int days[]={0,31,0,31,30,31,30,31,31,30,31,30,31};

int check(int x)
{
    int mou = (x%10)*10+(x/10)%10;
    int day = (x/100%10)*10+x/1000;

    if((x%4==0&&x%100!=0)||x%400==0) {
        if(mou==2&&day<=29) return 1;
    }
    else if(mou==2&&day<=28) return 1;

    if(mou<1||mou>12) return 0;
    if(x!=B.year ){
        if(days[mou]>=day) return 1; 
    }
    else {
        if(day<=B.day &&mou<=B.mou ) return 1;
    }
    return 0;
}

int main()
{
    scanf("%4d %2d %2d",&A.year ,&A.mou ,&A.day );
    scanf("%4d %2d %2d",&B.year ,&B.mou ,&B.day );
    int ans=0;
    for(int i = A.year ;i<= B.year ;i++){
        if(check(i) ) ans++;
    }
    cout<<ans<<endl;
    return 0;
 } 
xunzhang123 commented 4 years ago

include

include

include

include

using namespace std;

int months[13] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};

bool check(int date)//本题重点就在check函数要怎么写 { int year = date / 10000; int month = date % 10000 / 100; int day = date % 100; if (!month || month > 13 || !day) return false;//判断月份是否合法 if (month != 2 && day > months[month]) return false; if (month == 2)//对二月份特判 { bool leap = year % 4 == 0 && year % 100 || year % 400 == 0; if (day > 28 + leap) return false; } return true; } int main() { int date1, date2; cin >> date1 >> date2; int res = 0; for (int i = 0; i < 10000; i ++ ) { int x = i, r = i; for (int j = 0; j < 4; j ++ ) r = r * 10 + x % 10, x /= 10;//直接把r构造成一个回文串 if (r >= date1 && r <= date2 && check(r)) res ++ ;//如果日期合法就加1 } printf("%d\n", res); return 0; }

LJM-Jeson commented 4 years ago
#include <bits/stdc++.h>

using namespace std;

//各月天数
int days[13] = {0,31,28,31,30,31,30,31,31,30,31,30,31};

//判断日期是否合法
bool check_valid(int date){
    int year = date / 10000;
    int month = date % 10000 /100;
    int day = date % 100;

    if(month == 0 || month > 12) return false;
    if(day == 0 || month != 2 && day > days[month]) return false;

    if(month == 2){
        int leap = year % 100 && year % 4 == 0 || year % 400 == 0;
        if(day > 28 + leap) return false;
    }
    return true;
}

int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);

    int date1, date2;
    cin >> date1 >> date2;

    int ans = 0;

    //枚举回文日期
    for(int i = 1000; i < 10000; i ++){
        int date = i, x = i;
        for(int j = 0; j < 4; j ++) date = date * 10 + x % 10, x /= 10; //转化为八位正常日期
        if(date1 <= date && date <= date2 && check_valid(date)) ans ++;//判断回文日期范围是否合法,判断回文日期是否合法
    }

    cout << ans << endl;
    return 0;
}
maobohui commented 4 years ago
#include<bits/stdc++.h>
using namespace std;
int days[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int res = 0;
bool judge(int n){
    int year=n/10000;
    int month=(n%10000)/100;
    int day=n%100;
    if(month==0||month>12){
        return false;
    }
    if(day==0||month!=2&&day>days[month]){
        return false;
    }
    if(month==2){
        if(year%4==0&&year%100!=0||year%400==0){
            if(day>29){
                return false;
            }
        }
    }
    return true;
}
int start,en;
int main(){
    cin>>start>>en;
    for(int i=1000;i<=9999;i++){
        int j=i;int k=i;
        for(int i=1;i<=4;i++){
            j=j*10+k%10;
            k/=10;  
        }
        if(j>=start&&j<=en){
            if(judge(j)){
                res++;
            }
        }
    }
    cout<<res<<endl;
    return 0;
}